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Best Desktop Software Slideshow Makers with  

Photos and Music: 



Are you aware of how many photos are taken and then forgotten in the 
storage card? Photos of cute babies, 4-leg friends, birthday parties, 
weddings, and more. Using a photo slideshow maker can breathe life 
into those still photos. 
In fact, any video editor can be used as a slideshow maker, the only drawback is the amount of time and effort required if you are new to 
non-linear editing software.  

That's why the market of dedicated and easy-to-use slideshow makers blossom. 

A slideshow maker might have some or all of these options: 

• Add transitions 

• Add filters and adjust colours 

• Add background music 

• Add text and captions 

• Add video layovers such as stickers and PiP 

• Record your voice to add commentaries 

The difference lies in the degree of customizability each program allows, and that makes sense because those programs aim at different 
markets (for users at different skill levels).



Best Free Slideshow Makers for Windows and Mac 
1. Windows 10 Video Editor 

The default video editor for windows 10 is one of the best free slideshow makers for beginners. 

It is pre-installed, and comes with basic transition and motion effects enough for a quick making of photos slideshow with music.  

The best thing is, you can directly pick photos and videos already stored in the photos library, or import media from 
iPhone and Android mobiles. With each photo or video inserted to the storyboard, you can trim it or adjust duration, add 
captions, transitions and music. 

Pros: 

• Pre-installed app, easy to use 

• Lightweight for low-performance computer 

Cons: 

• Barebones for power users looking for highly 
customizable solutions

https://www.videoproc.com/video-editor/windows-10-video-editor-built-in.htm


2. iMovie 
If you are looking for the best free slideshow makers for Mac, iMovie ranks top on the list. Developed by Apple, this video editing application 
works nicely for slideshow making.  

You don't have to train yourself to get design-y, the themes and text styles in iMovie keep up with Apple's aesthetics.  

You can add enormous numbers of photos and video clips into the timeline, as long as the finished video falls within 60 minutes.

Pros: 

• Various stylish themes for quick slideshow making 

• Countless YouTube tutorials to guide you through 
slideshow making 

• Option to add and edit background music for the 
slideshow 

Cons: 

•  Changing the aspect ratio of the video is 
less straight-forward

https://www.apple.com/imovie/
https://www.videoproc.com/video-editor/imovie-review.htm
https://www.videoproc.com/video-editor/change-aspect-ratio.htm#imovie


3. ffDiaporama 
The interface of ffDiaporama does admittedly look a little dated at a first glance. But it is free and open source software, hard to beat that! 
You can turn photos into a video with music. 

This program has basic transition built-in, including commonly seen slide, zoom, fade, etc. Transitions can be applied between each photo, 
with the option to change speed.

3. ffDiaporama

Pros: 

• Option to quickly rearrange photos by 
dragging them 

• Support editing background music in the 
slides 

Cons: 

• Only provides some basic functions 

• No templates or storyboard to use

http://ffdiaporama.tuxfamily.org/
https://www.videoproc.com/video-editor/turn-pictures-into-video.htm
http://ffdiaporama.tuxfamily.org/


4. 4K Slideshow Maker
If you want an automatic photo slideshow wizard, 4K Slideshow Maker does the magic. 

 It automatically creates a video from photos you imported, and apply random but nice transitions and effects to the photos. 

 Popular effects such as ken burns will be added, giving you a view of panning and zooming to breathe life into still photos. It 
also allows you to adjust the duration of photos and transitions.

Pros: 

• Ready-to-use profiles to export video as the best format for iPhone,  

• Directly import photos from Instagram to create IG photo show 

• Option to use face detection tech to keep people in the frame 

Cons: 

• All the things you prefer to manually done is not possible in this program 

• No option to trim and cut background music and videos 

• Cannot add text or stickers to the video

https://www.4kdownload.com/products/product-slideshowmaker


5. Bolide Slideshow Creator
Bolide Slideshow Creator is a lightweight free slideshow maker, with a merely 9MB installation package. 

 The interface is archaic, with a design aesthetic from the Windows 7 era. All the basic needs can be 
fulfilled: add multiple photos to the storyboard, insert transitions between photos, add one piece of 
background music, and apply animated titles. 

 It works nicely if you only want to showcase photos with simple transitions. There is no photo college tool 
to stylize photos in each frame. Pros: 

• Lightweight and easy-to-use, suitable for low-spec 
machines 

• It supports up to 18 languages 

• Option to randomly arrange photos you added into the 
storyboard 

• 1-click make all photos landscape or portrait by cropping, 
zoom in, or letter box 

Cons: 

• Doesn't support 4K or higher resolutions 

• Cannot add and merge multiple pieces of music to one 
video 

• The output format is limited to AVI, MP4, WMV, MKV and 
FLV

https://slideshow-creator.com/


Windows 10 Video Editor Built-in - Photos App 
Don't rush to pay for any video editor for basic video processing, since Windows 10 has offered you a free video editor built-in - 
Photos.  

Based on our test, this Windows 10 hidden video editor is one of the best free entry-level editing software when novices need quick 
video editing. 

About the Built-in Windows 10 Video Editor - Photos 
You might be confused that why a video editing app is named as Photos.  

The truth is Microsoft Photos was originally planned as the default picture management tool for new Windows 10 operating system.  

The video editing feature was later added after a certain update (Fall Creators Update).  

Strictly speaking, Photos is a three-in-one media manager rather than a Windows 10 video editor app. 

Is Photos the Best Windows 10 Video Editor? 
There is no PERFECT software that suits all. Photos, without accurate frame-based adjustment settings, is nowhere near as 
professional as non-linear editing systems.  

But due to part of its advantages, Photos should be one of the best free Windows 10 free video editors for beginners to do some quick 
editing.

https://www.videoproc.com/video-editor/free-video-editors-software-review.htm


How to Use Windows 10 Video Editor Built-in 
Next, we will show you the complete steps of using the Windows 10 video editor built-in, from how to import videos, 

how to do editing (trim video, add text or music, apply filters, slow down video playback speed, add 3D effects and 
many more) to how to save and share file online.  

But remember that not all file types are acceptable.  

Video files like MP4, WMV, MOV, AVI, MKV and M2TS can be loaded while some others like FLV, VOB and ISO 
cannot. And, HEVC video requires installing additional codecs.



Step 1: Open video in Photos on Windows 10

To combine several clips and create a new movie:  

• Desktop > Taskbar > search for Photos > open the app > New video > New video project > name your video > OK 

• + Add > Add video "From this PC" or "From my collection" > select video > Add 

To edit a single video: Find your video file > right click the video > Open with > Photos 



Step 2: Trim video

To remove unwanted clips from your footage, click "Edit & Create" and choose "Trim" in the drop-down list. 

Step 3: Add Slo-mo

This Windows 10 hidden video editor provides you with three playback speed options: original speed, slower and 
super slow (turtle icon). But better not try the super slow one. It makes your video stutter and there is no slow-down 
effect. 

How to add slo-mo: Edit & Create > Add Slo-mo > specify a time range in timeline > switch from original to slower > 
Save a copy. 

Step 4: Apply filters

Edit & Create &gt; Create a video with Text > Name you video > Filters > select one of the filters like Classic, 
Adventure, Pearl, Iceberg, Sepia, Arcade, Inky, Pixel, etc.



Choose a filter in Photos



Step 5: Add Text

In the same "Create a video with Text" window, click "Text" right beside the "Filters" to add a title or caption. 
Write down the title, select an animated text style, choose the layout and then "Done". There are 15 Animated 
text styles, including Bold, Cinema, Fresh, IMPACT, Cartoon, etc. 

Step 6: Add 3D Effects

Still in the "Create a video with Text" window > 3D effects > wait for a moment as the built-in Windows 10 video 
editing app gets 3D effects ready for your video. 

Then switch to Effects > choose one among all effects > resize and rotate the effect > set a time range > Done.



Step 7: Save and share video online

After all the edits, you can save your video for uploading and sharing: 

Finish video > select a file size in "Export or share" > choose S for fast sharing in email and small screens > M for uploading to Facebook, 
Skype, Twitter, etc > L for playing on large screens like TV.



Create slideshows in Photos on Mac 
In Photos, there are two ways to create slideshows. 

You can quickly play a slideshow of the photos from a day, complete with a theme and music. 
If you want more control over the options in your slideshow, you can create and save a slideshow project. 

You select a group of photos, then add text, choose a theme, add music and set how long each slide appears. 
You can include video clips in a slideshow, and export the slideshow to play on a Mac, iPhone, iPad or Apple TV. 



Play an instant slideshow 
You can quickly play a slideshow of the photos from a day. You can select a theme and music for the slideshow, but you can’t 
customise the slideshow further.  

1. In the Photos app on your Mac, click Photos in the sidebar, then click Days in the toolbar.  

2. Select some photos from a day, then choose File > Play Slideshow.  

3. Click Themes, then select a theme. 
  
A preview of the theme appears in the pane.  

4. Click Music and select the song you want.  
  
To turn off music, click the song again to deselect it.  

5. Click Play Slideshow.  

To stop playing the slideshow, press the Escape key. You can also press the arrow keys to skip forward or back through the slides 
and press the Space bar to pause the slideshow. 



Create a slideshow project 
1. In the Photos app on your Mac, select the photos you want in your slideshow. 

  
You can add or remove photos later (see “Add or remove photos and text in  
a slideshow” below).  

2. Choose File > Create > Slideshow > Photos.  

3. Click the Slideshow pop-up menu and choose New Slideshow.  

4. Type a new name.  

5. To reorder photos, drag photos into the order you want them in the bottom  
of the window.  

6. To select a theme, click the Themes button , then click a theme. 
 You can change the theme at any time. The theme you choose determines text position, fonts and the transitions that appear between 
slides. The pan and zoom effect, also known as the Ken Burns effect, is available only for the Ken Burns theme.  

7. To select music for the slideshow, click the Music button , click the down arrow next to Music Library, then select a song or songs. 
 
Choose Theme Songs from the pop-up menu to see music included with Photos, or choose Music to see music from your Music library. 
Drag the songs you selected to change the order they play in. To delete a song, select it and press Delete. 
  



8. To change how long each slide appears, click the Duration button  
, then do any of the following (not all options are available for all themes):  

◦ Set the slideshow to match the length of the selected music: Select Fit to Music.  

◦ Set a specific display time for the slideshow: Select Custom, then drag the slider to specify how long the slideshow should 
play for.  

◦ Set a transition for the entire slideshow: Select the Transition tickbox, then choose a transition type from the pop-up menu.  

◦ Set slides to fit the screen: Select the “Scale photos to fit screen” tickbox.  

9. To see a preview of the slideshow, click the Preview button.  
 
Click Preview again to stop the preview. You can also set the slideshow to  
loop continuously by clicking the Loop button .  

10. To play the slideshow, click the Play button . 
To stop playing a slideshow, press the Escape key. You can also press the arrow keys to skip forward or back through the slides, 
and press the Space bar to pause the slideshow. 



Add or remove photos and text in a slideshow 
After you create a slideshow, you can add or delete photos at any time. You can also add text to selected slides. 
The text position and font is determined by the theme you chose. When you add a Live Photo to a slideshow, it 
appears as a still image. 

1. In the Photos app on your Mac, click a slideshow under Projects in the sidebar.  

2. Do any of the following:  

◦ Add more photos to a slideshow: Select a photo in the row of  
thumbnails at the bottom, click , then click Add Photos. Select the photos you want to add, then click Add.  

◦ Add text to a slide: Select a photo, click , then click Add Text. Select the text in the text box, then type the 
text you want.  

◦ Delete text from a photo: Select the text in the photo or select the T frame before the photo in the row of 
thumbnails, then press Delete.  

◦ Delete a photo from the slideshow: Select the photo you want to delete, then press Delete.  
 


